Example Network Configuration Scenarios

From Internet Computer Wiki
Jump to: navigation, search

Example one: IPv6 Gateway on the ISP device

Example network config 1.jpg

You have a network setup consisting of one or two switches. These switches are connected to a provider's IPv6 network, which has the address range 2a00:fb01:400:200::/64. This means that any traffic destined for the 2a00:fb01:400:200::/64 subnet will be directed to our network.

The gateway for this network is located on the ISP device, and its IPv6 address is 2a00:fb01:400:200::1. The gateway serves as the entry and exit point for your network, connecting it to the Internet.

Please note that these are simplified configurations assuming basic Layer 2 functionality with VLAN 1. Adjustments may be required based on your specific network requirements, such as additional VLANs or advanced features. Also, make sure to replace the IP addresses and gateway with your actual network information.

Additionally, note that the commands provided are general examples and may differ slightly depending on the specific device model and software version. Refer to the documentation or vendor resources for more precise command syntax and options for your particular network device.

Configuration of Switch01

  • Dell OS10:
hostname Switch01
! Configure interfaces connected to ISP, Servers and Switch02
interface ethernet 1/1/48
  description ISP:WAN
  switchport mode access
  switchport access vlan 1
!
interface range ethernet 1/1/1-1/1/14
  description Servers
  switchport mode access
  switchport access vlan 1
  spanning-tree port type edge
!
interface ethernet 1/1/47
  description SW01:SW02
  switchport mode access
  switchport access vlan 1
  • Cumulus:
net add hostname switch01
net add bridge bridge ports swp1-14,swp47,swp48
net add bridge bridge pvid 1
net add bridge bridge vids 1
net add bridge bridge vlan-aware
net add interface swp1-14,swp47,swp48
net commit
  • Cisco:
hostname Switch01
!
interface Ethernet1/1-14
  description Server
  switchport
  switchport mode access
  switchport access vlan 1
  spanning-tree port type edge
  no shutdown
!
interface Ethernet1/47
  description SW1:SW2
  switchport
  switchport mode access
  switchport access vlan 1
  spanning-tree port type network
!
interface Ethernet1/48
  description ISP
  switchport
  switchport mode access
  switchport access vlan 1
  spanning-tree port type network

Configuration of Switch02

  • Dell OS10:
hostname Switch02
! Configure interfaces connected to Servers and Switch01
interface range ethernet 1/1/1-1/1/14
  description Servers
  switchport mode access
  switchport access vlan 1
  spanning-tree port type edge
!
interface ethernet 1/1/47
  description SW02:SW01
  switchport mode access
  switchport access vlan 1
  • Cumulus:
net add hostname switch02
net add bridge bridge ports swp1-14,swp47
net add bridge bridge pvid 1
net add bridge bridge vids 1
net add bridge bridge vlan-aware
net add interface swp1-14,swp47
net commit
  • Cisco:
hostname Switch02
!
interface Ethernet1/1-14
  description Server
  switchport
  switchport mode access
  switchport access vlan 1
  spanning-tree port type edge
  no shutdown
!
interface Ethernet1/47
  description SW2:SW1
  switchport
  switchport mode access
  switchport access vlan 1
  spanning-tree port type network

Example two: Network terminated on Node Provider Router

Example network config 2.jpg

In this network setup, we have one or two switches, These switches are connected to a router/firewall. The router has been assigned the IPv6 network 2a00:fb01:400:200::/64, with a gateway address of 2a00:fb01:400:200::1. This network serves as the local LAN for the connected devices.

To establish connectivity with the internet, we have received a Point-to-Point (P2P) /126 IPv6 subnet from our network provider. This subnet allows connectivity between your router and the ISP endpoint. The ISP end of this subnet is 2a00:fb01:400:100::1/126, and we need to configure the WAN interface of our router with the address 2a00:fb01:400:100::3/126.

The network provider is routing the entire IPv6 network 2a00:fb01:400:200::/64 to the next hop on your end. To ensure proper forwarding of traffic, configure a default IPv6 route on your router pointing to the ISP device's next hop, which is 2a00:fb01:400:100::1. This route will direct any outgoing traffic not destined for your local network to the ISP.

Please note that these are simplified configurations assuming basic Layer 2 and Layer 3 functionality. Adjustments may be required based on your specific network requirements, such as additional VLANs or advanced features. Also, make sure to replace the IP addresses, routes, and gateway with your actual network information.

Configuration of Switch01

  • Dell OS10:
hostname Switch01
! Configure interfaces connected to RTR, Servers and Switch02
interface ethernet 1/1/48
  description RTR_FW
  switchport mode access
  switchport access vlan 1
!
interface range ethernet 1/1/1-1/1/14
  description Servers
  switchport mode access
  switchport access vlan 1
  spanning-tree port type edge
!
interface ethernet 1/1/47
  description SW01:SW02
  switchport mode access
  switchport access vlan 1
  • Cisco:
hostname Switch01
!
interface Ethernet1/1-14
  description Server
  switchport
  switchport mode access
  switchport access vlan 1
  spanning-tree port type edge
  no shutdown
!
interface Ethernet1/47
  description SW1:SW2
  switchport
  switchport mode access
  switchport access vlan 1
  spanning-tree port type network
!
interface Ethernet1/48
  description RTR_FW
  switchport
  switchport mode access
  switchport access vlan 1
  spanning-tree port type network

Configuration of Switch02

  • Dell OS10:
hostname Switch02
! Configure interfaces connected to Servers and Switch01
interface range ethernet 1/1/1-1/1/14
  description Servers
  switchport mode access
  switchport access vlan 1
  spanning-tree port type edge
!
interface ethernet 1/1/47
  description SW02:SW01
  switchport mode access
  switchport access vlan 1
  • Cisco:
hostname Switch02
!
interface Ethernet1/1-14
  description Server
  switchport
  switchport mode access
  switchport access vlan 1
  spanning-tree port type edge
  no shutdown
!
interface Ethernet1/47
  description SW2:SW1
  switchport
  switchport mode access
  switchport access vlan 1
  spanning-tree port type network

Configuration of RTR/FW

  • Cisco:
ipv6 unicast-routing
!
interface TenGigabitEthernet1
 no ip address
 negotiation auto
 ipv6 address 2A00:FB01:400:100::3/126
!
interface TenGigabitEthernet2
 no ip address
 negotiation auto
 ipv6 address 2A00:FB01:400:200::1/64
 ipv6 enable
!
ipv6 route ::/0 2A00:FB01:400:100::1

Example three: Network terminated on Node Provider L3 Switch (SVI or routed ports)

Example network config 3.jpg

In this network setup, we have one or two switches, These switches are connected to an ISP network. The ISP has allocated a Point-to-Point (P2P) /126 IPv6 subnet for our use. The ISP's endpoint is assigned the IPv6 address 2a00:fb01:400:100::1/126, and we need to configure the interface of our switch with the IPv6 address 2a00:fb01:400:100::3.

To establish connectivity between our network and the ISP, the provider is routing the IPv6 network 2a00:fb01:400:200::/64 to the next hop on our end. This means that any traffic destined for the 2a00:fb01:400:200::/64 subnet will be directed to our network.

To ensure proper routing within our network, we need to configure the switches accordingly. Firstly, we assign the IPv6 address 2a00:fb01:400:100::3/126 to the interface of Switch01, enabling communication with the ISP.

On Switch01, we set up a default IPv6 route that points to the next hop provided by the ISP, which is 2a00:fb01:400:100::1. This default route allows any traffic with an unknown destination within our network to be forwarded to the ISP.

Additionally, we advertise the routed subnet 2a00:fb01:400:200::/64 within our network by configuring the interface on Switch01 connected to our internal network. This interface is assigned the IPv6 address 2a00:fb01:400:200::1/64. By enabling IPv6 routing on Switch01, the subnet is made accessible to devices within our network.

With these configurations in place, our network is set up to communicate with the ISP using the provided IPv6 addressing scheme. Switch01 acts as the gateway, forwarding traffic to the ISP's next hop, and enabling connectivity to the routed subnet 2a00:fb01:400:200::/64 within our network.

Please note that these are simplified configurations assuming basic Layer 2 and Layer 3 functionality. Adjustments may be required based on your specific network requirements, such as additional VLANs or advanced features. Also, make sure to replace the IP addresses, routes, and gateway with your actual network information.

Configuration of Switch01

  • Dell OS10:
hostname Switch01
!
interface vlan10
 no shutdown
 ipv6 nd send-ra
 ipv6 address 2a00:fb01:400:200::1/64
!
! Adding default route
ipv6 route ::/0 2a00:fb01:400:100::1
!
! Configure interfaces connected to Servers and Switch01
interface range ethernet 1/1/1-1/1/14
  description Servers
  switchport mode access
  switchport access vlan 10
  spanning-tree port type edge
!
interface ethernet 1/1/47
  description SW01:SW02
  switchport mode trunk
  switchport trunk allowed vlan 10
  • Cumulus:
net add hostname switch01
net add vlan 1 ipv6 nd prefix 2a00:fb01:400:200::/64
net del vlan 1 ipv6 nd suppress-ra
net add routing route ::/0 2a00:fb01:400:100::1
net add bridge bridge ports swp1-14,swp47
net add bridge bridge pvid 1
net add bridge bridge vids 1
net add bridge bridge vlan-aware
net add interface swp1-14,swp47
net add interface swp48 ipv6 address 2a00:fb01:400:100::3/126
net add vlan 1 ipv6 address 2a00:fb01:400:200::1/64
net add vlan 1 vlan-id 1
net commit
  • Cisco:
hostname Switch01
! Enable feature for VLAN Routing
feature interface-vlan
!
interface Vlan10
  no shutdown
  ipv6 address 2a00:fb01:400:200::1/64
  ipv6 nd prefix default infinite infinite
!
! Configure port toward ISP
interface Ethernet1/48
  description ISP
  no switchport
  ipv6 address 2a00:fb01:400:100::3/126
  no shutdown
!
interface Ethernet1/1-14
  description Server
  switchport
  switchport mode access
  switchport access vlan 10
  spanning-tree port type edge
  no shutdown
!
interface Ethernet1/47
  description SW1:SW2
  switchport
  switchport mode access
  switchport access vlan 10
  spanning-tree port type network

!
ipv6 route ::/0 2a00:fb01:400:100::1
!

Configuration of Switch02

  • Dell OS10:
hostname Switch02
!
interface vlan10
 no shutdown
!
! Configure interfaces connected to Servers and Switch01
interface range ethernet 1/1/1-1/1/14
  description Servers
  switchport mode access
  switchport access vlan 10
  spanning-tree port type edge
!
interface ethernet 1/1/47
  description SW02:SW01
  switchport mode trunk
  switchport trunk allowed vlan 10
  • Cumulus:
net add hostname switch02
net add bridge bridge ports swp1-14,swp47
net add bridge bridge pvid 1
net add bridge bridge vids 1
net add bridge bridge vlan-aware
net add interface swp1-14,swp47
net commit
  • Cisco:
hostname Switch02
!
interface Ethernet1/1-14
  description Server
  switchport
  switchport mode access
  switchport access vlan 10
  spanning-tree port type edge
  no shutdown
!
interface Ethernet1/47
  description SW2:SW1
  switchport
  switchport mode access
  switchport access vlan 10
  spanning-tree port type network


Example four: Using Recursive DNS Server (RDNSS) on Gateway

The RDNSS option is included in the RA message sent by the router. It contains the IP addresses of one or more Recursive DNS Servers that the hosts can use to resolve domain names to IP addresses. When an IPv6-enabled host receives an RA, it checks for the presence of the RDNSS option. If it finds one, the host updates its DNS configuration with the provided DNS server addresses. The RDNSS option allows hosts to leverage the benefits of DNS resolution in an IPv6 network.

Below you will find examples of captured RA ICMPv6 packet containing the Recursive DNS Servers

Internet Control Message Protocol v6
    Type: Router Advertisement (134)
    Code: 0
    Checksum: 0xa9a8 [correct]
    [Checksum Status: Good]
    Cur hop limit: 64
    Flags: 0x00, Prf (Default Router Preference): Medium
    Router lifetime (s): 1800
    Reachable time (ms): 0
    Retrans timer (ms): 0
    ICMPv6 Option (Source link-layer address : 0c:94:ad:2c:00:01)
        Type: Source link-layer address (1)
        Length: 1 (8 bytes)
        Link-layer address: 0c:94:ad:2c:00:01 (0c:94:ad:2c:00:01)
    ICMPv6 Option (MTU : 1500)
        Type: MTU (5)
        Length: 1 (8 bytes)
        Reserved
        MTU: 1500
    ICMPv6 Option (Recursive DNS Server 2606:4700::1111 2001:4860:4860::8888)
        Type: Recursive DNS Server (25)
        Length: 5 (40 bytes)
        Reserved
        Lifetime: 1000
        Recursive DNS Servers: 2606:4700::1111
        Recursive DNS Servers: 2001:4860:4860::8888
    ICMPv6 Option (Prefix information : 2a00:fb01:400:200::/64)
        Type: Prefix information (3)
        Length: 4 (32 bytes)
        Prefix Length: 64
        Flag: 0xc0, On-link flag(L), Autonomous address-configuration flag(A)
        Valid Lifetime: 2592000
        Preferred Lifetime: 604800
        Reserved
        Prefix: 2a00:fb01:400:200::

Configuration examples

  • Dell OS10:
interface ethernet1/1/1
 ipv6 address 2a00:fb01:400:200::1/64
 ipv6 nd prefix default
! Example Cloudflare and Google DNS
 ipv6 nd ra-dns server seq 1 2606:4700::1111 1000
 ipv6 nd ra-dns server seq 2 2001:4860:4860::8888 1000
 ipv6 nd send-ra
  • Cumulus:
sudo vtysh
!
interface swp1
 ipv6 nd rdnss 2001:4860:4860::8888 infinite
 ipv6 nd rdnss 2606:4700::1111 infinite
end
write memory
  • Cisco:
interface TenGigabitEthernet2
 ipv6 address 2A00:FB01:400:200::1/64
 ipv6 enable
! Example Cloudflare and Google DNS
 ipv6 nd ra dns server 2606:4700::1111 1000
 ipv6 nd ra dns server 2001:4860:4860::8888 1000